Sunday, 31 October 2010

Makerbot #453 : MK5 motor problem...

I'm trying to use my MK5 and need to calibrate Skeinforge. But how can I do that if the motor always stop in the middle of the print and restart by itself ? That append many times in the print. Doesn't look to be the board since the LED turn on when it should. It's a new motor with the little electronic board inside. I think I will try with my old motor from MK4 (one without the board inside) to be sure if it's the motor or something else...
Maybe I will have a week of printing without any issues...... someday...

Friday, 22 October 2010

Makerbot #453 : Homing in place

Last night I took some time to make my Start and End script for Skeinforge so I will not have to recenter my plastruder each time.
First, I was using G0 X100 Y100  to push the build plate at the end but I found that it took some time after reaching the endstop before doing the next steps. It took Much much longer time also with the G0 Z-50. It took about 2 minutes before doing next commands.
I found that G28 works better. No waiting time when reaching the endstop. I had to make some modification to my Z endstop triggers. I know it's not looking really good but it works. Next time I will make one in ABS with the possibility to adjust it.


(beginning of start.txt)
M104 S220 T0 (Extruder Temperature to 220 Celsius)
M109 S100 T0 (Heated Platform Temperature to 110 Celsius)
M107 (fan off)
G21 (Metric FTW)
G90 (Absolute Positioning)
G92 X0 Y0 Z0 (You are now at 0,0,0)
G0 Z5 ( Go higher to be safe)
G28 X0 Y0 ;go home ( XY at the MAX)
G28 Z0 ( Go down with Z)
G92 X0 Y0 Z0 (You are now at 0,0,0)
G0 Z1.5 (Higher a little bit to clear the place)
M6 T0 (Wait for tool to heat up)
G0 X57.5 Y45 (Put the build plate in the center)
G0 Z-1.5 (return to the base)
G92 X0 Y0 Z0 (You are now at 0,0,0)
(end of start.txt)

(beginning of end.txt)
(end of the file, cooldown routines)
M104 S0 T0 (temp zero)
M109 S0 T0 (platform off)
M106 (fan on)
G21
G92 Z0 (zero our z axis - hack b/c skeinforge mangles gcodes in end.txt)
G91
G0 X100 Y100 Z20 (
M18 (turn off steppers.)
G04 P120000
M107 (fan off)
(end of end.txt)






video

Makerbot #453 : MK5 working !!

My bot is now working with my MK5 installed. Doesn't took me too much time to build and it works right on the first time. OK, some adjustments need to be done but i was able to print a 15MM cube and a whistle :-)

I also updated firmwares with latest one from ReplicatorG 20 and for the first time I was able to print raftless without any adjustment. It was not perfect but far better than before.



Monday, 18 October 2010

Makerbot #453 : MK5 on my desk !

YES !! Just received my MK5 kit. Should start to look at that tonight. Hope to make my Bot working soon, before the 1 year anniversary ;-)
This will be a big test compare to my last use : New Plastruder, New ReplicatorG, New Skeinforge.
If all go well , I plan to buy the ABP. I wanted to take it at the same time of buying my MK5 to save on shipping but I need to be sure I will be able to print correctly before any other big ($$)  addition to my Bot.

Wednesday, 6 October 2010

Makerbot #453 : Waiting for my Plastruder MK5

It's so hard to calibrate everything on the cupcake :-(
I don't have enough time in my life to spend on calibration. I so hope for a process to calibrate the machine. Meanwhile, I will try with the new MK5 from Makerbot . I hope This will help me to start printing more then just some little pieces of crap. By the time the MK5 come home, I will try to set my machine to find is 0,0,0 before each print.
.